Recomendaciones de Servicios para el funcionamiento de Woomelly


En esta guía, proporcionaremos recomendaciones de servicios para el funcionamiento de Woomelly para WordPress. El complemento ha sido desarrollado para no consumir recursos ineficientes que puedan afectar el rendimiento de tu tienda en WooCommerce. Si no experimentas problemas de rendimiento antes de instalar Woomelly en tu tienda en línea, tampoco los tendrás una vez que instales el complemento.

Además, se ha establecido un límite de 5,000 artículos, ya que este es el número estimado de productos para garantizar el correcto funcionamiento de la herramienta y las configuraciones de los servidores que alojan tiendas en WooCommerce.

Contenido

→ Recomendaciones de Servicios para Woomelly
→ ¿Desde que versión de WooCommerce y WordPress funciona Woomelly?
→ Cuenta de Mercado Libre
→ Tareas Programadas (WordPress Cron Jobs)
→ Habilitar IPs de Mercado Libre en el servidor de la tienda

Recomendaciones de Servicios para Woomelly

El primer paso para poder comenzar a trabajar con Woomelly es configurar una tienda en línea con el complemento WooCommerce en un entono WordPress. Pero antes de hacerlo, debe verificar su entorno de alojamiento (servidor). Al igual que WooCommerce recomendamos (no limitativo, pero si recomendable):

Es importante señalar que la versión de PHP inferior a 7.3+ y la versión de MySQL inferior a 5.6 ya no reciben soporte activo y muchas versiones están al final de su vida útil y, por lo tanto, ya no se mantienen. Como tal, el uso de versiones obsoletas y no compatibles de MySQL y PHP puede exponer su sitio a vulnerabilidades de seguridad.

¿Desde que versión de WooCommerce y WordPress funciona Woomelly?

El complemento Woomelly depende del entorno WordPress y del complemento WooCommerce, por lo tanto, al igual que WooCommerce.com menciona:

All extensions and themes sold on WooCommerce.com support the latest minor release of WooCommerce and WordPress core, and the previous two before that. The WooCommerce versions are in the SemVer format ( Major.Minor.Patch ) which started in version 3.0.0. For example, if the current version is 4.5.x then the oldest WooCommerce version we support is 4.3.x. Ideally, you are running the latest version of WooCommerce and are staying updated with the most secure version of WordPress.

Esto quiere decir, que si se cuenta con una versión desactualizada de WordPress o WooCommerce, existirán módulos que no funcionarán en la herramienta para esa tienda en línea. Incluso, la versión 3.6.0 ha sido la menor de WooCommerce donde ha logrado funcionar la herramienta y para WordPress ha sido la versión 5.3. Actualmente, el plugin Woomelly es compatible con la versión de WooCommerce y la versión WordPress indicadas en el mismo.

Cuenta de Mercado Libre

Para poder usar el plugin Woomelly, la cuenta de Mercado Libre que se vincule debe de tener el perfil de administrador. De esta forma, tendrá los permisos suficientes para poder realizar las consultas con Mercado Libre. Si la cuenta es un usuario operador/colaborador, el acceso no será válido y no podrás utilizar la herramienta.

Adicionalmente, al haber un cambio de seguridad en la cuenta de Mercado Libre (como cambiar la contraseña) ocasionará que se pierda la autorización vigente, por lo que se tendrá que hacer el mismo procedimiento de autorización. El plugin Woomelly funciona para todas las cuentas de Mercado Libre (particular, tienda oficial, etc.) y para cualquier país que esté incluido en la plataforma de Mercado Libre.

Tareas Programadas (WordPress Cron Jobs)

El complemento Woomelly utiliza tareas programadas de WordPress, algunas de las cuales son vitales para su funcionamiento. Por lo tanto, la tienda en línea debe de contar con esta funcionalidad activa, ya sea las tareas programadas por defecto de WordPress o activar las tareas programadas directamente desde el servidor (opción muy usada para mejorar rendimiento a los sitios en WordPress). Puedes leer este artículo para obtener más información.

Habilitar IPs de Mercado Libre en el servidor de la tienda

Para evitar errores de bloqueo con Mercado Libre, es recomendable colocar las IPs de Mercado Libre en el whitelist del servidor (escala esta solicitud con el soporte del hosting) y habilitar la conexión directa entre la tienda WooCommerce con la API de Mercado Libre (https://api.mercadolibre.com):

  • 216.33.196.4
  • 216.33.196.25
  • 54.88.218.97
  • 18.215.140.160
  • 18.213.114.129
  • 18.206.34.84
  • Todas las IPs relacionadas con api.mercadolibre.com

Fuente: Conexión/ bloqueo.

Enlaces relacionados:

5/5 - (1 voto)